Most popular browsers support all Guarda Web Wallet features. Make sure you are using a browser with a version not lower than recommended:

  • Chrome 63+ 
  • Edge    42+
  • Firefox    57+
  • Safari    12

We cannot guarantee the stability of all browsers that have an older version and which are not listed.



Follow us 


Twitter